compilation problem of python on AIX 6.1

Amit amit.kumar.iitr at gmail.com
Mon Jul 13 08:42:02 CEST 2009


Hello

I want to intsall python on my AIX 6.1 Box.
I couldn't get any rpm for python 2.5.x for AIX 6.1.

THen I decided to compile python 2.5.4 on my AIX box. I downloaded the
python source code from www.python.org and tried to compile on my AIX
both using gcc.

step 1 ./configure --with-gcc
configuration runs successfully

step 2 make
it gives me error

	case $MAKEFLAGS in  *-s*)  CC='gcc -pthread' LDSHARED='./Modules/
ld_so_aix gcc -pthread -bI:Modules/python.exp' OPT='-DNDEBUG -g -
fwrapv -O3 -Wall -Wstrict-prototypes' ./python -E ./setup.py -q
build;;  *)  CC='gcc -pthread' LDSHARED='./Modules/ld_so_aix gcc -
pthread -bI:Modules/python.exp' OPT='-DNDEBUG -g -fwrapv -O3 -Wall -
Wstrict-prototypes' ./python -E ./setup.py build;;  esac
running build
running build_ext
building 'bz2' extension
gcc -pthread -fno-strict-aliasing -DNDEBUG -g -fwrapv -O3 -Wall -
Wstrict-prototypes -I. -I/avre/Python-2.5.4/./Include -I. -IInclude -
I./Include -I/avre/Python-2.5.4/Include -I/avre/Python-2.5.4 -c /avre/
Python-2.5.4/Modules/bz2module.c -o build/temp.aix-6.1-2.5/avre/
Python-2.5.4/Modules/bz2module.o
building '_tkinter' extension
./Modules/ld_so_aix gcc -pthread -bI:Modules/python.exp build/
temp.aix-6.1-2.5/avre/Python-2.5.4/Modules/_tkinter.o build/
temp.aix-6.1-2.5/avre/Python-2.5.4/Modules/tkappinit.o -L/usr/X11/lib -
ltk8.4 -ltcl8.4 -lX11 -o build/lib.aix-6.1-2.5/_tkinter.so
*** WARNING: renaming "_tkinter" since importing it failed: 	0509-022
Cannot load module build/lib.aix-6.1-2.5.
	0509-026 System error: A file or directory in the path name does not
exist.

plz suggest



More information about the Python-list mailing list