2.3 missing on OSX

Philip Semanchuk philip at semanchuk.com
Thu Jul 23 23:03:41 CEST 2009


On Jul 23, 2009, at 4:53 PM, Laran Evans wrote:

> I just tried to run MacVim on OSX 10.5. It crashed with this:
>
> Dyld Error Message:
>  Library not loaded: /System/Library/Frameworks/Python.framework/
> Versions/2.3/Python
>  Referenced from: /Users/laran/Downloads/MacVim-7_2-stable-1_2/
> MacVim.app/Contents/MacOS/Vim
>  Reason: image not found
>
> I posted to the MacVim mailing list and was told that that version of
> 2.3 should always be available because it comes with the OS.

OS X 10.4 shipped with Python 2.3 as the system Python.

OS X 10.5 ships with Python 2.5 as the system Python. 2.3 is not  
available unless you install it yourself. And if you install it  
yourself, I wouldn't put it where MacVim is looking for it because the  
System folder is OS X stuff. If MacVim (or any app) contains a  
hardcoded reference to /System/.../2.3/Python, then it will break on  
OS X 10.5.





More information about the Python-list mailing list