"Deprecated sets module" with Python 2.6

Gabriel Genellina gagsl-py2 at yahoo.com.ar
Wed Jul 29 08:58:39 CEST 2009


En Tue, 28 Jul 2009 17:28:09 -0300, Virgil Stokes <vs at it.uu.se> escribió:

> I would appreciate help on correcting a problem when trying to create an  
> *.exe file using py2exe via GUI2exe with Python 2.6.2.
>
> When using GUI2exe to create an *.exe I always get the following warning  
> during the compile process:
>
>  C:\Python26\lib\site-packages\py2exe\build_exe.py:16:
>  DeprecationWarning: the sets module is deprecated
>  import sets

Note that build_exe.py is part of the py2exe package - the warning says  
that py2exe itself is importing a deprecated module, it's not in your code.

> and this results in the creation of an *.exe file that can not be  
> executed.

I don't think the warning above is related to your problem. Are you using  
the latest py2exe version?
You may get more help in the py2exe mailing list; see  
http://www.py2exe.org/

-- 
Gabriel Genellina




More information about the Python-list mailing list