No PyPI search for 3.x compatible packages

Neil Hodgson nyamatongwe+thunder at gmail.com
Thu Jul 30 01:55:34 CEST 2009


   There appears to be no way to search PyPI for packages that are
compatible with Python 3.x. There are classifiers for 'Programming
Language' including 'Programming Language :: Python :: 3' but that seems
to be for implementation language since there are so many packages that
specify C. There are a total of 109 packages classified with Python ::
[3, 3.0, 3.1] out of a total of 4829 packages.
http://pypi.python.org/pypi?:action=browse&show=all&c=214&c=533

   The search box appears to search for any word entered so a search
like "xml 3.0" or "xml AND 3.0" does not help.

   Some packages include version information in the Py Version column of
their download lists or embedded in the download file names. Projects
are often constrained to a particular set of Python versions so need to
choose packages that will work with those versions. It would be helpful
if PyPI made this information more visible and searchable.

   Neil



More information about the Python-list mailing list