Confessions of a Python fanboy

Colin J. Williams cjw at ncf.ca
Thu Jul 30 12:18:07 EDT 2009


Some have treated this as a troll.  I don't.
r wrote:
[snip]

> 1.) No need to use "()" to call a function with no arguments.
> Python --> "obj.m2().m3()" --ugly
>   Ruby --> "obj.m1.m2.m3"  -- sweeet!
> Man, i must admit i really like this, and your code will look so much
> cleaner.
> 
+1
> 2.) the .each method
> container.each{|localVar| block}
> This method can really cleanup some ugly for loops, although i really
> like the readability of for loops.
> 
Not clear.
> 3.) true OOP
> Now before you go and get all "huffy" over this statement, hear me
> out. Python is the best language in the world. But it damn sure has
> some warts! "len(this)" instead of "obj.length" max(that) instead of
> [1,2,3,4,5].max(). You know what i am talking about here people. We
> all get complacent and It seems easier to just cope with these
> problems instead of fighting for change. But look at the French,  WHAT
> THE HELL HAS THAT DONE FOR THEM, *NOTHING*!!!!
> 
+0.6
or better [1, 2, 3, 4, 5].len or [1, 2, 3, 4, 5].max

What has this got to do with "true OOP"?

[snip]



More information about the Python-list mailing list