install older Python version parallel

A. Cavallo a.cavallo at mailsnare.com
Thu Jun 11 18:51:35 CEST 2009


Hi,

I'm working on a project of mine that does creates python installation under 
/opt so they can be installed side by side with a system installed one.

There's a web page:

http://pyvm.sourceforge.net/

With links to the newest build plus all teh accompaining unitests.

But you can use the sources rpm to create a version with python 2.4 (see 
http://download.opensuse.org/repositories/home:/cavallo71:/opt-python-
interpreters/openSUSE_11.1/src/)

Let me know if you need more help,


Regards,
Antoino

On Thursday 11 June 2009 15:50:06 S. Dornseifer wrote:
> Hi everybody,
>
> The situation:
> I wrote a GUI, based on Python, TkInter and Pmw.
> It runs perfectly fine with Python 2.4 (providing, TkInter and Pmw are
> installed). But it crashes with Python 2.6. I tried this on MacOSX11.4
> and various Linux Distributions.
> Crashes occurs when I activate a Pmw.Diaog (I guess this is due to a bug
> in the installed blt package), also when I use setitems on
> Pmw.OptionMenu (I guess this is due to another package, associated with
> tcl/tk).
>
> The target:
> I have to get my GUI work under openSUSE 11.1 (x86_64).
>
> My plan:
> On my openSUSE 11.1 (x86_64), Python 2.6 is installed by default.
> I would like to know, how to install Python 2.4 along with TkInter and
> Pmw (and packages that are required by them), parallel to the existing
> Python 2.6. So that I do not break other software that depends on Python
> 2.6.
>
> If you can think of another plan, I would be also glad to discuss it.
>
> Cheers,
> Simon




More information about the Python-list mailing list