install older Python version parallel

Simon212 at Simon212 at
Fri Jun 12 11:54:55 CEST 2009

> > Hi everybody,
> >
> > The situation:
> > I wrote a GUI, based on Python, TkInter and Pmw.
> > It runs perfectly fine with Python 2.4 (providing, TkInter and Pmw are  
> > installed). But it crashes with Python 2.6. I tried this on MacOSX11.4  
> > and various Linux Distributions.
> > Crashes occurs when I activate a Pmw.Diaog (I guess this is due to a bug
> > in the installed blt package), also when I use setitems on  
> > Pmw.OptionMenu (I guess this is due to another package, associated with 
> > tcl/tk).
> You might get more helpful responses if you say more than just "it  
> crashes".
> What's the traceback?

Thanks for the suggestion.

Here is what it says when I try to use setitems on a Pmw.OptionMenu to refresh its contents:

com.read_config_file ./.mWIN/profiles/last.profile
Traceback (most recent call last):
  File "./", line 1323, in <module>
    frontEnd = FrontEnd(root)
  File "./", line 854, in __init__
  File "./", line 1216, in loadProfile
  File "/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/site-packages/Pmw/Pmw_1_3/lib/", line 67, in setitems
    self._menu.delete(0, 'end')
  File "/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/lib-tk/", line 2675, in delete
  File "/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/lib-tk/", line 358, in deletecommand
_tkinter.TclError: can't delete Tcl command

In case of the activation of a Pmw.Diaog it just gives me a segmentation vault.

GMX FreeDSL Komplettanschluss mit DSL 6.000 Flatrate und Telefonanschluss
für nur 17,95 Euro/mtl.!*

More information about the Python-list mailing list