Asking for prophecy

Mensanator mensanator at aol.com
Fri Mar 6 21:04:50 CET 2009


On Mar 6, 1:23 pm, "andrew cooke" <and... at acooke.org> wrote:
> 3 and 2.6 are compatible.  so develop on 3, to make sure you don't use old
> junk, and then switch to 2.6 if you need to.  there are a few wrinkles in
> doing so, but it is not a big problem.
>
> 3.0 is a nicer language.  it's cleaner and more consistent.  i think
> important libraries will move there.  

Probably, but until gmpy is available for 3.0,
3.0 does not exist yet as far as I'm concerned.

> no-one wants to do a perl.  it's the
> likely future and you can always jump back to 2.6 if needed.
>
> and in the long term, we will all die.
>
> andrew
>
>
>
> Stefan Spoettl wrote:
> > In the pass it was always a good idea to use the newest Python verison for
> > starting the development of a new application. First one could benefit
> > from the additional features and second one could be sure that the
> > community would have been passing during development.
>
> > Nowadays we have at least three Python versions (2.5, 2.6, 3.0) on our
> > machines and - damned! - I really don't know which version I should use
> > for my next development. The Unix-like systems as much as the major part
> > of well maintained third party libraries are remaining "penetrantly" on
> > 2.5. Why the vangard of the community don't like to use at least 2.6 for
> > bridging to the future Python? Is this the mutiny against the empery of
> > the BDFL or is the vangard just asking for some more time? If I want to
> > attest my personal attachment to the king by using 3.0, what will happen?
> > Will I be deserted someday?
>
> > Stefan--
> >http://mail.python.org/mailman/listinfo/python-list- Hide quoted text -
>
> - Show quoted text -




More information about the Python-list mailing list