Installing PLPython - Version Problem

ray Ray.Joseph at
Mon Mar 30 02:51:11 CEST 2009

I am trying to get Python 2.6 and PostgreSQL 8.3 to work together
under Windows 2000.

When I try to add Python to PostgreSQL via:
createlang plpythonu dbname

But when doing so, I get an error:
createlang: language installation failed: ERROR:  could not load
library "C:/Program Files/PostgreSQL/8.3/lib/createlang: language
installation failed: ERROR:  could not load library "C:/Program Files/
PostgreSQL/8.3/lib/plpython.dll": The specified module could not be

So I Used "depends" to walk the references of plpython.dll, I found
that it can not find python25.dll.  Since I have 2.6, only
python26.dll is in ...system32.

1) The first question is how do I get this stack to look for the 2.6

If I make a copy of python26.dll and rename it python25.dll, that
reference is resolved but a new one appears for apphelp.dll:
Error opening file.  The system cannot find the file specified (2).
Warning: At least on delay-load dependency module was not found.
Warning:  At least on module has an unresolved import due to a missing
export function in a delayed-load dependent module.

2) I do not find apphelp on my system.  Where do I get a copy and
where should it be placed?

When I rename the dll to python26, the PL installed without error.
But I am concerned that something else is wrong.  I would really like
to find out how to get this to install correctly on production


More information about the Python-list mailing list