Unable to build libpython2.5.so on OS X 10.4

Ned Deily nad at acm.org
Thu May 7 19:36:49 CEST 2009


In article 
<0e05eca2-b460-4e01-aa54-cc1055f51e7d at q14g2000vbn.googlegroups.com>,
 elwinter <elwinter at verizon.net> wrote:
> The Python module I am building is actually the Python module
> for ROOT, a large package from CERN. However, the problem arises
> before that code enters the picture, when I am building Python itself.
> All I want to do is create "libpython2.5.dylib", or its equivalent,
> and I can't seem to make that happen on Tiger.

Any chance you can use the python.org installer for 2.5.4?  Or the 
Macports version?  They both are supported on Tiger.

<http://www.python.org/download/releases/2.5.4/>
<http://www.macports.org/>

Again, I may be missing something but libpythonx.x by itself is not very 
useful, i.e. it's not your usual standalone lib.  You'll almost 
certainly need the whole python installation.  There are a number of 
ways to build python on OS X (google will find them or ask on the Mac 
python sig) but, unless you have some special requirement, use an 
existing python installation and build the ROOT Python module with that.

-- 
 Ned Deily,
 nad at acm.org




More information about the Python-list mailing list