Freezing python files into executables

Girish Venkatasubramanian girishvs at gmail.com
Tue Nov 3 20:15:39 CET 2009


Hello,
I have been using freeze.py on 32 bit linux distributions without a
problem. But recently I tried to do the same on RHEL5 x86_64 and ran
into some issues.

1) When I ran the script, I got
Error: needed directory /usr/lib/python2.4/config not found

2) Then I "yum install python-devel" which installed python-devel.i386
and python-devel.x86_64. Then when I tried freezing, it worked but
make barfed up a bunch of errors during ld like

/usr/bin/ld: warning: i386 architecture of input file
`/usr/lib/python2.4/config/libpython2.4.a(rangeobject.o)' is
incompatible with i386:x86-64 output

and

/usr/lib/python2.4/config/libpython2.4.a(posixmodule.o): In function
`posix_getcwd':
(.text+0x53a1): undefined reference to `PyEval_RestoreThread'

3) I tried uninstalling python-devel.i386 (retaining only the x86_64)
and freeze fails with the same error message as in 1

Any help with this is greatly appreciated.
Thanks



More information about the Python-list mailing list