problem in installing wxwidgets for python..

Jebagnana Das jebagnanadas at gmail.com
Wed Nov 4 12:37:19 CET 2009


Hello friends,
                  I've tried to install wxwidgets in my mandriva 2009 spring
for GUI interaction with python. In the installation instruction it said
that i need gtk+ library. So i downloaded GTK+. When i configured GTK+ i got
the message

checking for BASE_DEPENDENCIES... configure: error: Package
requirements (glib-2.0 >= 2.21.3    atk >= 1.13.0    pango >= 1.20
cairo >= 1.6) were not met:

Requested 'glib-2.0 >= 2.21.3' but version of GLib is 2.20.1

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables BASE_DEPENDENCIES_CFLAGS
and BASE_DEPENDENCIES_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.


Then i downloaded glib2.21.3,atk 1.13.0,pango 1.20 and cairo 1.6. I
installed all the packages using the following commands.

tar xvzf filename.tar.gz
cd folder
./configure
make
make install

I've not specified anf options like --prefix and i installed in the folder
itself.
when i tried to install gtk+ after installing all this it showed the same
error. What should i do to install wxwidgets? Plz. reply as soon as
possible.. Coz. i've to finish my proj. quickly.. Thanks and regards...
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/python-list/attachments/20091104/fde00b8b/attachment.html>


More information about the Python-list mailing list