problem in installing wxwidgets for python..

Ishwor Gurung ishwor.gurung at gmail.com
Wed Nov 4 13:11:39 CET 2009


Hi,

2009/11/4 Jebagnana Das <jebagnanadas at gmail.com>:
> Hello friends,
>                   I've tried to install wxwidgets in my mandriva 2009 spring
> for GUI interaction with python. In the installation instruction it said
> that i need gtk+ library. So i downloaded GTK+. When i configured GTK+ i got
> the message

You probably want wxpython binding instead - http://www.wxpython.org/
Use binaries provided by Mandriva's package manager where possible
unless you _really_ want to do a source installation.

> checking for BASE_DEPENDENCIES... configure: error: Package requirements
> (glib-2.0 >= 2.21.3    atk >= 1.13.0    pango >= 1.20    cairo >= 1.6) were
> not met:
>
>
> Requested 'glib-2.0 >= 2.21.3' but version of GLib is 2.20.1
>
> Consider adjusting the PKG_CONFIG_PATH environment variable if you
> installed software in a non-standard prefix.

$ export PKG_CONFIG_PATH=/usr/lib/pkgconfig:/usr/local/lib/pkgconfig
(considering that your local installs went to those directories. Try
replacing those directories accordingly for glib, atk, pango and
cairo). The files you're after is a ".pc" (pkg-config need them) file.
A quick find will tell you where it is if it is installed.

Run configure script again.

> Alternatively, you may set the environment variables
> BASE_DEPENDENCIES_CFLAGS
>
> and BASE_DEPENDENCIES_LIBS to avoid the need to call pkg-config.
> See the pkg-config man page for more details.
>
> Then i downloaded glib2.21.3,atk 1.13.0,pango 1.20 and cairo 1.6. I
> installed all the packages using the following commands.

[...]
> tar xvzf filename.tar.gz
> cd folder
> ./configure
>
> make
> make install

Yep. Check where it installed them one by one. In short, you need
access to a ".pc" file that they provide. If not, write one yourself.

> I've not specified anf options like --prefix and i installed in the folder
> itself.

man pkg-config for further info.

> when i tried to install gtk+ after installing all this it showed the same
> error. What should i do to install wxwidgets? Plz. reply as soon as
> possible.. Coz. i've to finish my proj. quickly.. Thanks and regards...

See above.
-- 
Regards,
Ishwor Gurung



More information about the Python-list mailing list