python bijection

Gregory Ewing greg.ewing at canterbury.ac.nz
Wed Nov 25 00:49:10 CET 2009


Joshua Bronson wrote:
> So I'm
> thinking of renaming the class injectivedict or idict instead of
> bijection. Is that crazy?)

I think you'd be better off calling it something more
down-to-earth such as bidict (bidirectional dictionary).
That way people without an advanced degree in mathematics
have a better shot at not being baffled by it.:-)

-- 
Greg



More information about the Python-list mailing list