python bijection

Joshua Bronson jabronson at gmail.com
Wed Nov 25 04:28:38 CET 2009


On Nov 24, 6:49 pm, Gregory Ewing <greg.ewing at canterbury.ac.nz> wrote:
> Joshua Bronson wrote:
> > So I'm
> > thinking of renaming the class injectivedict or idict instead of
> > bijection. Is that crazy?)
>
> I think you'd be better off calling it something more
> down-to-earth such as bidict (bidirectional dictionary).
> That way people without an advanced degree in mathematics
> have a better shot at not being baffled by it.:-)
>
> --
> Greg

heh, duly noted:) bidict it is!



More information about the Python-list mailing list