Are there any modules for IRC, that work with Python 3.1?

TerryP bigboss1964 at gmail.com
Fri Oct 16 01:27:57 CEST 2009


On Oct 15, 10:36 pm, a... at pythoncraft.com (Aahz) wrote:
> Why do you think that would be wise?  If library writers haven't upgraded
> their libraries to 3.1, shouldn't that be a message to you?

To me, it generally sends this kind of message:

if lib.has_lots_of_users:
  try:
    avoid.as_long_as_possible()
  except AvoidError:
    pass
  finally:
    migrate_or_die()
elif lib is unmaintained:
  raise CrapException("you're on your own bub!")
else:
  you.go_back_to_work(on_project, you.with(lib))


but being late for dinner might be clouding my mind at the
moment.... ;)



More information about the Python-list mailing list