Some issue with easy_install and PIL/Imaging

Chris Withers chris at simplistix.co.uk
Fri Sep 11 15:49:50 CEST 2009


Klein Stéphane wrote:
> Resume :
> 1. first question : why PIL package in "pypi" don't work ?

Because Fred Lundh have his package distributions unfortunate names that 
setuptools doesn't like...

> 2. second question : when I add PIL dependence in my setup.py and I do
>    "python setup.py develop", I've this error :
>    "error: Could not find required distribution Imaging".
>    Why ?

See above.

> Now, I add --find-links parameter to easy_install :

If you google harder, you'll find there are packagings of PIL that do 
work with setuptools...

Chris

-- 
Simplistix - Content Management, Batch Processing & Python Consulting
            - http://www.simplistix.co.uk



More information about the Python-list mailing list