using python 2.5

Dave Angel davea at ieee.org
Tue Sep 22 09:12:58 CEST 2009


kunal.k wrote:
> I have installed python 2.5 for a particular code. Now i have 2.6
> already installed. How do i direct this code to use the 2.5 modules??
>
>   
I can think of two different questions you might be asking.  1) How do I 
get the add-on modules installed with 2.6 to also work in 2.5?  or 2) 
How do I get a particular script to use 2.5, while all other scripts 
should use 2.6 ?

Sean answered #1, but I think you meant to ask #2

First question is what OS you've installed these on.  In Windows, the 
python version is selected by file associations, while in Unix/Linux 
systems, it's selected by the shebang line at the beginning of the script.

A generic answer if you just have one script is to make an OS script 
(bat file, or shell script) that invokes the particular python 
interpreter, passing it the script name as an argument).

But if you want to be able to just run the script as though it were a 
compiled executable, tell us what OS you're on, and maybe the base 
locations of your two installations.

DaveA




More information about the Python-list mailing list