Gentoo, Cygwin: Import Error time, cStringIO, Permission denied

Elmar Hinz oss.elmar at
Mon Aug 23 12:41:48 CEST 2010

> Problem
> ======
> After compiling pyhton I run into errors when I start to use it in
> form of emerge. It says something like this in the logger module:
> Import Error sys, os, types, time, string, cStringIO, traceback.
> Permission denied.
> I researched the web. One discssion told to try it on the pyhton
> shell. I did the same. Only "time" and "cStringIO" are not imported.
> Looking into the compiled sources i find cStringIO.dll and time.dll.
> Both have the permissions 755. Hence permission to run them should be
> given.

I tried something different. I tried to run emerge with Cygwins
precompiled python.

In this case I get a related but different error:

fatal error - unable to map
\\?\F:\cygwin\lib\pyhton2.6\lib-dynload\time.dll to same address as

0x330000 != 0x3A0000

What does this mean? Is there a naming conflict between pythons
time.dll and a time.dll of the windows system?


More information about the Python-list mailing list