adodbapi help needed

Ian hobson42 at gmaiil.com
Tue Aug 24 22:38:55 CEST 2010


  On 24/08/2010 18:08, Emile van Sebille wrote:
> On 8/24/2010 8:25 AM Ian Hobson said...
>> Hi all,
>>
>> I am just starting to learn Python and I have a setup problem - I think.
>> Python 3.1.
>>
>
> <snip>
>
>>
>> def connect(connection_string, timeout=30):
>>
>> I expected that to be called.
>>
>> What have I missed?
>>
>
>
>
> The current revision includes the caveat:
>
> This module source should run correctly in CPython versions 2.3 and 
> later, or IronPython version 2.6 and later, or, after running through 
> 2to3.py, CPython 3.0 or later.
>
> Does that help?
>
> Emile
>
Thanks for the response Emile,

I have also removed all my Python installations and started again - with 
same result.
After installing Python3.1 and pywin32-214.win32-py3.1.exe  (which 
includes adodbapi)
I was getting System does not exist.

I have run 2to3.py on adodbapi and I still get this trackback.

D:\websites\moschatel\sop\Printing>test.py
Traceback (most recent call last):
   File "D:\websites\moschatel\sop\Printing\test.py", line 16, in <module>
     import adodbapi
   File "C:\Python31\lib\site-packages\adodbapi\__init__.py", line 1, in 
<module>

     from .adodbapi import *
   File "C:\Python31\lib\site-packages\adodbapi\adodbapi.py", line 57, 
in <module
 >
     from System import Activator, Type, DBNull, DateTime, Array, Byte
ImportError: No module named System

I suspect that is movement, not progress.  :)

Regards

Ian





More information about the Python-list mailing list