How to guard against bugs like this one?
pavlovevidence at gmail.com
Wed Feb 3 23:34:13 CET 2010
On Feb 2, 8:52 pm, Steven D'Aprano
<ste... at REMOVE.THIS.cybersource.com.au> wrote:
> On Tue, 02 Feb 2010 19:55:15 -0800, Carl Banks wrote:
> > On Feb 2, 5:49 pm, Steven D'Aprano
> > <ste... at REMOVE.THIS.cybersource.com.au> wrote:
> >> On Tue, 02 Feb 2010 12:26:16 -0800, Carl Banks wrote:
> >> > I did not propose obvious module names. I said obvious names like
> >> > email.py are bad; more descriptive names like send_email.py are
> >> > better.
> >> But surely send_email.py doesn't just send email, it parses email and
> >> receives email as well?
> > No, it doesn't.
> Nevertheless, as a general principle, modules will tend to be multi-
> purpose and/or generic.
If your module is a library with a public API, then you might
defensibly have a "generic and/or multi-purpose module", but if that's
the case you should have already christened it something unique.
Otherwise modules should stick to a single purpose that can be
summarized in a short action word or phrase.
More information about the Python-list