SMTPServerDisconnected

Victor Subervi victorsubervi at gmail.com
Wed Feb 24 18:09:24 CET 2010


On Tue, Feb 23, 2010 at 4:53 PM, Jonathan Gardner <
jgardner at jonathangardner.net> wrote:

> On Tue, Feb 23, 2010 at 8:47 AM, Victor Subervi <victorsubervi at gmail.com>
> wrote:
> > Hi;
> > I think the last main thing I have to do on my server is get a running
> email
> > server up. Now that I've nuked sendmail and given up on postfix, I'm back
> to
> > trying to get qmail up and running again. Of course, there are no active
> > discussion lists for *any* email server, so I have to turn here for help.
> > While running a script that worked perfectly well on another server to
> send
> > an email, I get the following error:
> > A problem occurred in a Python script. Here is the sequence of function
> > calls leading up to the error, in the order they occurred.
> > A problem occurred in a Python script. Here is the sequence of function
> > calls leading up to the error, in the order they occurred.
> >  /var/www/html/globalsolutionsgroup.vi/simplemail/mail2.py
> >    52 </head>
> >    53 <body>'''
> >    54 my_mail()
> >    55 print '''
> >    56 </body>
> > my_mail = <function my_mail>
> >  /var/www/html/globalsolutionsgroup.vi/simplemail/mail2.py in my_mail()
> >    33       to_address = ourEmail1,
> >    34       subject = subject,
> >    35       message = message
> >    36   ).send()
> >    37   Email(
> > message = 'Name: beno -\nMessage: test'
> >  /var/www/html/globalsolutionsgroup.vi/simplemail/simplemail.py in
> > send(self=<simplemail.Email object>)
> >   344         smtp = smtplib.SMTP()
> >   345         if self.smtp_server:
> >   346             smtp.connect(self.smtp_server)
> >   347         else:
> >   348             smtp.connect()
> > smtp = <smtplib.SMTP instance>, smtp.connect = <bound method SMTP.connect
> of
> > <smtplib.SMTP instance>>, self = <simplemail.Email object>,
> self.smtp_server
> > = 'localhost'
> >  /usr/lib64/python2.4/smtplib.py in connect(self=<smtplib.SMTP instance>,
> > host='localhost', port=25)
> >   305         if not self.sock:
> >   306             raise socket.error, msg
> >   307         (code, msg) = self.getreply()
> >   308         if self.debuglevel > 0: print>>stderr, "connect:", msg
> >   309         return (code, msg)
> > code undefined, msg = 'getaddrinfo returns an empty list', self =
> > <smtplib.SMTP instance>, self.getreply = <bound method SMTP.getreply of
> > <smtplib.SMTP instance>>
> >  /usr/lib64/python2.4/smtplib.py in getreply(self=<smtplib.SMTP
> instance>)
> >   349             if line == '':
> >   350                 self.close()
> >   351                 raise SMTPServerDisconnected("Connection
> unexpectedly
> > closed")
> >   352             if self.debuglevel > 0: print>>stderr, 'reply:',
> > repr(line)
> >   353             resp.append(line[4:].strip())
> > global SMTPServerDisconnected = <class smtplib.SMTPServerDisconnected>
> > SMTPServerDisconnected: Connection unexpectedly closed
> >       args = ('Connection unexpectedly closed',)
> > I cannot find the qmail logs. I assumed they'd be in either
> > /var/qmail/supervise/qmail-send
> > or
> > /var/qmail/supervise/qmail-smtpd
> > but I find no logs there.
> >
> > [SSH] Protocol Version 2 (OpenSSH_4.3)
> > [SSH] Cipher: aes128-cbc
> > Logged in (password)
> > Last login: Tue Feb 23 05:24:00 2010 from 66.248.168.67
> > [beno at 13gems ~]$ su
> > Password:
> > [root at 13gems beno]# man netstat
> > [root at 13gems beno]# netstat
> > Active Internet connections (w/o servers)
> > Proto Recv-Q Send-Q Local Address               Foreign Address
> > State
> > getnameinfo failed
> > tcp        0    268 nrelectric.com:ssh          [UNKNOWN]:61912
> > ESTABLISHED
> > Active UNIX domain sockets (w/o servers)
> > Proto RefCnt Flags       Type       State         I-Node Path
> > unix  7      [ ]         DGRAM                    10842  /dev/log
> > unix  2      [ ]         DGRAM                    10370
> >  @/org/kernel/udev/udevd
> > unix  2      [ ]         DGRAM                    6077731
> > unix  3      [ ]         STREAM     CONNECTED     6077679
> > unix  3      [ ]         STREAM     CONNECTED     6077678
> > unix  2      [ ]         DGRAM                    6077675
> > unix  2      [ ]         DGRAM                    11556
> > unix  2      [ ]         DGRAM                    11511
> > unix  2      [ ]         DGRAM                    10990
> > [root at 13gems beno]#
> >
> > How do I trouble-shoot this?
>
> Try connecting to the port that is supposed to accept mail messages
> via telnet and issue a few SMTP commands.
>

Oops. I just realized I posted this twice to the same forum. My bad. I have
advanced on this somewhat. I have gotten email from my server, so I know
that smtp is in fact working. But I'm still getting this error. What do?
TIA,
beno
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/python-list/attachments/20100224/0b485992/attachment.html>


More information about the Python-list mailing list