interactive terminal in Ubuntu Linux : libreadline5-dev works only in Python 2.6 not 3.1

Dave Dave
Wed Jan 13 06:49:05 CET 2010


On Wed, 13 Jan 2010 03:29:05 +0430, Lee Harr <missive at hotmail.com>
wrote:
>When you first had this problem, was python3 installed from
>source, or was it from the Ubuntu repository? 
>
>(ie, did you install using apt-get or synaptic or did you just start
>out building from source?)
>
>I have python 3 on Ubuntu 9.10 installed using synaptic and
>readline works fine.
>
>If yours was from the repo, it's possible that the problem is not
>python, but your terminal emulator. Which terminal program
>are you using (xterm, konsole, gnome-terminal, etc)?

Lee ,

Over a month ago I downloaded the tarball Python-3.1.1 from
the python website.  Then the Synaptic Package Manager did not
contain this ( latest ) version. There is already python 2.x on my 
Ubuntu 9.04 ( think its 2.6 ).  Think I saw 3.0 on Synaptic but
not 3.1  Supposedly 3.1 has faster i/o .

I know less about Ubuntu than python. I struggled with Linux for 
several weeks. On Jan 2  I attempted installation ( in dir containing
Python-3.1.1 ) with :
    $  ./configure
    $  make
    $  make test
    $  sudo make install

Did not seem to work ( didn't record exactly what happened, perhaps
I didn't put in sudo ), so I ran above again.  Did not use altinstall.

Did not get the tarball with apt-get or from Synaptic.  Just downloaded
it from python site.  The readme gave the "build" instructions above.

I've exclusively used gnome.  Quite happy with gedit's handling of
python code.

I shouldn't have been greedy and should have settled for 3.0
from Synaptic.

Now I have problems with three versions on my machine.  Please see
my exchanges with casevh for details.

Perhaps the best solution would be to wipe off all 3.1 versions and
simply install 3.0 from Synaptic.

This whole thing with the Python interactive interpreter keys actually
started with my sons, who are Mac enthusiasts. One gave me a MacBook.
Alas the Python interpreter keys were fouled up, as well as it having a
"simplified" keyboard. Apple took it back, but it was disconcerting when
I found the same key problem in Ubuntu python 3.1  Apple must change
their software as I retried a new MacBook yesterday. To my great
surprise the python 2.6 interpreter worked fine, while on at least two
MacBooks last month it did not.

Thanks for your help,     Dave     pdlemper at earthlink.net



More information about the Python-list mailing list