python 3's adoption

Jonathan Gardner jgardner at jonathangardner.net
Thu Jan 28 02:50:55 EST 2010


On Jan 27, 4:25 pm, Paul Rubin <no.em... at nospam.invalid> wrote:
>  What about assert and pass?
>

If you're going to have statements, you're going to need the null
statement. That's "pass". It could be renamed "null_statement" but
"pass" is a better description. "None" and "pass" are cousins of
sorts, since "None" is the null expression and "pass" the null
statement.

I agree on "assert". I don't like running a program in test mode and
then running it in production mode with different code. I would rather
test what I am going to actually run. "assert" should be a function,
and support for removing assert statements should be eliminated. I
simply don't use assert statements at all.



More information about the Python-list mailing list