cxfreeze on ubuntu 9.10

Waspinator patrickwasp at
Thu Mar 25 01:33:35 CET 2010


I'm trying to compile a python script on Ubuntu 9.10. It uses the gtk
toolkit. I tried to run GUI2EXE for a cxfreeze gui, but even after
installing wxPython in synaptic it still complains about not having

I also tried to use cxfreeze by itself but the file it produces does
not run.

I tried to follow the information at

I created a file that looks like this (from the page)

from cx_Freeze import setup, Executable

        name = "gtk_test",
        version = "0.1",
        description = "gtk_test",
        executables = [Executable("")])

and ran:

python build

When I try to run the executable I get the following error:

RuntimeWarning: tp_compare didn't return -1 or -2 for exception
ImportError: could not import gio
ImportError: could not import gio
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.6/cx_Freeze/initscripts/", line 29, in <module>
    exec code in m.__dict__
  File "", line 274, in <module>
  File "", line 228, in main
AttributeError: 'module' object has no attribute 'Window'

I was thinking of using the 'copy-dependent-files' option but I'm not
sure how.

Any ideas?


More information about the Python-list mailing list