pythoncom.CoInitialize() not recognised in Eclipse

KB keith at nekotaku.com
Mon Mar 29 19:50:18 CEST 2010


On Mar 28, 10:59 pm, "Dieter Verfaillie" <diet... at optionexplicit.be>
wrote:
> Quoting KB <ke... at nekotaku.com>:
>
> > I am getting an error from the IDE saying it does not recognise
> > CoInitialize():
>
> > ****
> > import pythoncom
>
> > pythoncom.CoInitialize()
> > pythoncom.CoUninitialize()
> > ****
>
> It works out of the box with PyDev 1.5.5.2010030420 on Eclipse 3.5.2  
> on Windows XP. If nothing seems to work for you, you could try adding  
> pythoncom to the
> "Forced Builtins" tab of your Python interpreter configuration to see if it
> helps (restart eclipse after you've done that, sometimes changes to  
> the symbols
> database don't get picked up without restarting eclipse...)

Dieter, Thanks, I tried updating my PyDev and Eclipse to your
versions.

Still same issue. How exactly would I add pythoncom to the Forced
Builtins ? I tried simply adding "pythoncom" to the Forced Builtin's
tab but no change.

Any suggestions?



More information about the Python-list mailing list