Problem installing psycopg2 in virtualenv (Ubuntu 10.04, Python 2.5)

Pascal Polleunus ppo at especific.be
Tue Oct 5 08:41:52 CEST 2010


On 05/10/10 00:11, Diez B. Roggisch wrote:
> Pascal Polleunus<ppo at especific.be>  writes:
>
>> Hi,
>>
>> I've problems to install psycopg2 in a virtualenv on Ubuntu 10.04.
>>
>>
>> My problem is also explained on stackoverflow:
>> http://stackoverflow.com/questions/3847536/installing-psycopg2-in-virtualenv-ubuntu-10-04-python-2-5
>>
>>
>> I tried different things explained there:
>> http://www.saltycrane.com/blog/2009/07/using-psycopg2-virtualenv-ubuntu-jaunty/
>>
>> The last thing I tried is this...
>> I created a virtualenv with -p python2.5 --no-site-packages
>> I installed libpq-dev: apt-get install libpq-dev
>>
>> In the virtualenv, I did this: easy_install -i
>> http://downloads.egenix.com/python/index/ucs4/ egenix-mx-base
>>
>> Then when I tried pip install psycopg2==2.0.7, I got this error:
>>
>> Installing collected packages: psycopg2
>> Running setup.py install for psycopg2
>> building 'psycopg2._psycopg' extension
>> gcc -pthread -fno-strict-aliasing -DNDEBUG -g -fwrapv -O2 -Wall
>> -Wstrict-prototypes -fPIC -DPSYCOPG_DEFAULT_PYDATETIME=1
>> -DPSYCOPG_VERSION="2.2.2 (dt dec ext pq3)" -DPG_VERSION_HEX=0x080404
>> -DPSYCOPG_EXTENSIONS=1 -DPSYCOPG_NEW_BOOLEAN=1 -DHAVE_PQFREEMEM=1
>> -DHAVE_PQPROTOCOL3=1 -I/usr/include/python2.5
>> -I. -I/usr/include/postgresql -I/usr/include/postgresql/8.4/server -c
>> psycopg/psycopgmodule.c -o
>> build/temp.linux-i686-2.5/psycopg/psycopgmodule.o
>> -Wdeclaration-after-statement
>> psycopg/psycopgmodule.c:27:20: error: Python.h: No such file or directory
>> In file included from psycopg/psycopgmodule.c:31:
>> ./psycopg/python.h:31:26: error: structmember.h: No such file or directory
>> ./psycopg/python.h:34:4: error: #error "psycopg requires Python>= 2.4"
>> In file included from psycopg/psycopgmodule.c:32:
>>
>>
>> Does anyone have any idea how to solve that?
>
> Install the python-dev-package. It contains the Python.h file, which the
> above error message pretty clearly says. Usually, it's a good idea to
> search package descriptions of debian/ubuntu packages for missing header
> files to know what to install.

It's already installed; at least for 2.6, nor sure it's correct for 2.5.
python2.5-dev is not available but python-old-doctools replaces it.

Here's what is installed:

ii  python2.5            2.5.4-1ubuntu6.1
ii  python2.5-minimal    2.5.4-1ubuntu6.1
ii  python-old-doctools  2.5.5-1
ii  python2.6            2.6.5-1ubuntu6
ii  python2.6-dev        2.6.5-1ubuntu6
ii  python2.6-minimal    2.6.5-1ubuntu6
ii  python-dev           2.6.5-0ubuntu1



More information about the Python-list mailing list