Problem installing psycopg2 in virtualenv (Ubuntu 10.04, Python 2.5)

Alex Willmer alex at
Tue Oct 5 10:18:29 CEST 2010

On Oct 5, 7:41 am, Pascal Polleunus <p... at> wrote:
> On 05/10/10 00:11, Diez B. Roggisch wrote:
> > Install the python-dev-package. It contains the Python.h file, which the
> > above error message pretty clearly says. Usually, it's a good idea to
> > search package descriptions of debian/ubuntu packages for missing header
> > files to know what to install.
> It's already installed; at least for 2.6, nor sure it's correct for 2.5.
> python2.5-dev is not available but python-old-doctools replaces it.

Ubuntu 10.04 doesn't have a full Python 2.5 packaged, as evidenced by
the lack of python2.5-dev. You need to use Python 2.6 or if you
absolutely must use Python 2.5 build it from source, try a Debian
package or switch distro. python-old-doctools does not replace python-
dev, it looks like it was bodged to keep some latex tools working.

Regards, Alex

More information about the Python-list mailing list