Starting Python in XP Pro

Grant Andrew gveggie at
Sun Oct 17 05:27:11 CEST 2010

I hear that...God knows if I had a more complete question, I'd type it -
basically, when I click the IDLE GUI icon from the Start Menu, there is a
flash of a command prompt loading, then nothing happens.

I've tried a number of things at the command prompt over the last two weeks
and five versions.  I went to ActiveState because I was thinking I had not
configured something properly in the versions, however, the
behavior is the same.

I ran C:\>C:\python26\lib\idlelib\ at the command prompt and that

Traceback (most recent call last):
  File "C:\python26\lib\idlelib\", line 21, in <module>
  File "C:\Python26\lib\idlelib\", line 1386, in main
    root = Tk(className="Idle")
  File "C:\Python26\lib\lib-tk\", line 1643, in __init__ = _tkinter.create(screenName, baseName, className, interactive,
objects, useTk, sync, use)
_tkinter.TclError: Can't find a usable init.tcl in the following
    {C:\IBMTOOLS\Python22\tcl\tcl8.4} C:/IBMTOOLS/Python22/tcl/tcl8.5
6/lib/tcl8.5 C:/lib/tcl8.5 C:/lib/tcl8.5 C:/library C:/library
ry C:/tcl8.5.8/library

C:/IBMTOOLS/Python22/tcl/tcl8.4/init.tcl: version conflict for package
"Tcl": ha
ve 8.5.8, need exactly 8.4
version conflict for package "Tcl": have 8.5.8, need exactly 8.4
    while executing
"package require -exact Tcl 8.4"
    (file "C:/IBMTOOLS/Python22/tcl/tcl8.4/init.tcl" line 19)
    invoked from within
"source C:/IBMTOOLS/Python22/tcl/tcl8.4/init.tcl"
    ("uplevel" body line 1)
    invoked from within
"uplevel #0 [list source $tclfile]"

This probably means that Tcl wasn't installed properly.

I hope this helps.  Thanks again for any help.


On Sat, Oct 16, 2010 at 6:30 PM, Dave Angel <davea at> wrote:

>  On 2:59 PM, Grant Andrew wrote:
>> I'm a beginning user with some challenges.  I have installed and
>> uninstalled
>> several versions with the same results - I can't get IDLE to work, nor can
>> I
>> associate .py files with Python.
>> So I can get the interactive shell interface but nothing else.  I'm
>> currently running ActiveState 2.6.
>> Any thoughts on where to begin are appreciated.
>> Thanks!
>> Grant
>>  You could start by writing a more complete question.  Exactly what have
> you tried, and in what way does it "not work" ?  Show what you typed at the
> command prompt, and just what error messages you got.  Use copy & paste,
> don't retype it.
> With the ActiveState default install, you shouldn't need to create your own
> association;  it should already be done by the installation.  However, if
> you install multiple versions, and don't properly uninstall, it might change
> the default.
> Have you tried running python.exe explicitly?
> DaveA
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Python-list mailing list