pylint -- should I just ignore it sometimes?

Seebs usenet-nospam at
Wed Oct 20 23:09:02 CEST 2010

On 2010-10-20, Matteo Landi <landimatte at> wrote:
> Another situation in which I needed to disable such kind of warnings
> is while working with graphics modules.
> I often use variable names such as x, y, z for coordinates, or r,g,b for colors.
> Would longer names make the reader's life easier?

Interesting point.  Which is really easier to read:

	x, y, z = p.nextpoint()

	xCoordinate, yCoordinate, zCoordinate = polygon.nextPointCoordinates()

Copyright 2010, all wrongs reversed.  Peter Seebach / usenet-nospam at <-- lawsuits, religion, and funny pictures <-- get educated!
I am not speaking for my employer, although they do rent some of my opinions.

More information about the Python-list mailing list