Python 2.7 module path problems on OS X

Nicholas Cole nicholas.cole at gmail.com
Sun Sep 5 10:49:00 CEST 2010


Dear List,

I have a horrible feeling that this is in some way related to the new
user installation directory in 2.7,or some problem with the framework
built, but I'm having great trouble with the module search path on
2.7.

I usually install modules to install_lib =
~/Library/Python/$py_version_short/site-packages

I assumed that this would continue to work on 2.7.

Unfortunately, it seems not to. The installation is fine, but sys.path
only includes

'/Library/Frameworks/Python.framework/Versions/2.7/lib/python27.zip',
'/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7',
'/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/plat-darwin',
'/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/plat-mac',
'/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/plat-mac/lib-scriptpackages',
'/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-tk',
'/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-old',
'/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload',
'/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages'

Whereas on 2.6 on my system the default is the more extensive:

'/Users/nicholas/Library/Python/2.6/site-packages/docutils-0.5-py2.6.egg',
'/Users/nicholas/Library/Python/2.6/site-packages/py2app-0.4.3-py2.6.egg',
'/Users/nicholas/Library/Python/2.6/site-packages/macholib-1.2.1-py2.6.egg',
'/Users/nicholas/Library/Python/2.6/site-packages/modulegraph-0.7.3-py2.6.egg',
'/Users/nicholas/Library/Python/2.6/site-packages/altgraph-0.6.7-py2.6.egg',
'/Users/nicholas/Library/Python/2.6/site-packages/bdist_mpkg-0.4.4-py2.6.egg',
'/System/Library/Frameworks/Python.framework/Versions/2.6/lib/python26.zip',
'/System/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6',
'/System/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/plat-darwin',
'/System/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/plat-mac',
'/System/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/plat-mac/lib-scriptpackages',
'/System/Library/Frameworks/Python.framework/Versions/2.6/Extras/lib/python',
'/System/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/lib-tk',
'/System/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/lib-old',
'/System/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/lib-dynload',
'/Library/Python/2.6/site-packages',
'/System/Library/Frameworks/Python.framework/Versions/2.6/Extras/lib/python/PyObjC',
'/System/Library/Frameworks/Python.framework/Versions/2.6/Extras/lib/python/wx-2.8-mac-unicode',
'/Users/nicholas/Library/Python/2.6/site-packages'

I'm sorry to ask such a trivial question on the list, but I'm used to
python installations "Just working"!  Can anyone suggest a good fix?

Best wishes,

Nicholas



More information about the Python-list mailing list