Python 2.6 & bsddb

Sridhar Ratnakumar sridharr at
Tue Sep 21 18:58:32 CEST 2010

On 2010-09-21, at 9:04 AM, garyr wrote:

> I recently installed ActivePython 2.6.6 and my programs that use anydbm or 
> shelve generate import errors because bsddb is missing. I installed bsddb3 
> (bsddb3-5.0.0.win32-py2.6.exe) but that didn't change anything. What more do 
> I need to do?

You may have to change the imports. Maybe from "import bsddb" to "import bsddb3". The API may be different. Read the bsddb3 documentation.


More information about the Python-list mailing list