Error installing cx_Oracle

AMC arunmohan.c at
Wed Sep 22 13:35:41 CEST 2010


>From last months I am using Python for making small but useful tools
for my team members. I am doing my development in windows machine and
running the program in Solaris machine where Python 2.6.2 is

In one of my program file I had to use the module "cx_Oracle".For that
I have installed the module in my windows machine and done the
programming. But the finished program does not run in Solaris machine,
may be because "cx_Oracle" was not installed there.Following is the
error shown.

root at access1:/home/amohan/python/work/broadcast_report/bin$ ./
Traceback (most recent call last):
  File "./", line 3, in <module>
    import cx_Oracle
ImportError: isapython2.6: fatal: /opt/webstack/python/lib/
python2.6/site-packages/ wrong ELF class: ELFCLASS64
root at access1:/home/amohan/python/work/broadcast_report/bin$

I tried installing "cx_Oracle" with easy_install utility (I am not
strong in Solaris). While installing I am getting some error as shown

root at access1:/$ easy_install cx_Oracle
Searching for cx-Oracle
Best match: cx-Oracle 5.0.4
Processing cx_Oracle-5.0.4.tar.gz
Running cx_Oracle-5.0.4/ -q bdist_egg --dist-dir /tmp/
"SessionPool.c", line 200: warning: integer overflow detected: op "<<"
ld: fatal: library -lpython2.6: not found
ld: fatal: File processing errors. No output written to build/
error: Setup script exited with error: command '/opt/webstack/python/
lib/python2.6/pycc' failed with exit status 1
root at access1:/$

I have searched for a solution everywhere and tried many things but
didn't work. Can somebody help me in this?


More information about the Python-list mailing list