Determining version of OpenSSL

Martin v. Loewis martin at v.loewis.de
Mon Apr 4 23:44:56 CEST 2011


> import ssl
> ssl.OPENSSL_VERSION
> 
> is there a way that this can be done in python2.4? It's annoying but I
> need to support python2.4 for a while yet :-(

ldd /usr/lib/python2.4/lib-dynload/_ssl.so
[...]
        libssl.so.0.9.8 => /usr/lib/libssl.so.0.9.8 (0x00007f6a5a9b7000)
[...]

HTH,
Martin



More information about the Python-list mailing list