Messed up Mac installation

aspineux aspineux at
Tue Aug 16 06:33:36 EDT 2011

On Aug 16, 12:03 pm, Christopher Brewster <cbrews... at> wrote:
> Are there instructions somewhere online as to how to sort out a messed
> up installation of Python on a Mac?
> I have a 2 month old Macbook running Snow Leopard, I installed Python
> 2.7.1 some time ago. Now when I run 'python' this is what it shows.
> But easy_install and pip are installing modules to the python2.6
> (which shipped with the OS). If I run 'python2.6' then I have access
> to the modules installed with pip.

pip and easy_install work on directory hierarchy of the running

then  the idea (just the idea, not read sample)

python2.7 **** will install into python2.7 directories
python2.7 **** will install into python2.7 directories

python2.6 **** will install into python2.6 directories
python2.6 **** will install into python2.6 directories

For example (real this time) to install easy_install for your 2.7


> Oh and weirdly if I tell pip to uninstall modules it says the module
> does not exist. For example: "/Library/Frameworks/Python.framework/
> Versions/2.7/bin/pip run on Tue Aug 16 11:46:28 2011
> Cannot uninstall requirement reportlab, not installed"

Probably because you run installed pip from python2.7 directory, that
certainly use python2.7 binary,
and then pip uninstall from python2.7 directories

> So why is it installing to one place (the 2.6 library) and trying to
> uninstall elsewhere (the 2.7 library)?

Because you are no using the same pip/easy_install to install or
uninstall (or at least the python binary is not the same)

> I know this has been discussed many times but I do not know how to
> track this down.
> Thanks for any pointers.
> Christopher

More information about the Python-list mailing list