Multiplicity and Asininity in Tkinter Event API

Chris Angelico rosuav at
Fri Jul 15 16:02:25 CEST 2011

On Fri, Jul 15, 2011 at 11:54 PM, rantingrick <rantingrick at> wrote:
> Ok Mr. Pedantic. I suppose for unity sake we should use the sequence
> name "<MousePress>" instead of <MouseClick>. I'll give you that one.

It is very significant; if you call it Click, people will assume it
means Press, Release within a certain maximum time and without more
than a maximum amount of movement (in some cases 0 movement, others
permit a mickey or two).

Yes, that's all that's actually needed. But if you force programmers
to process the low-level events, you put load on them that they don't
need. It's possible to define every program in terms of a handful of
operations - do you want to ditch all of Python's rich syntax and
library in favour of that?


More information about the Python-list mailing list