Scikits.timeseries for 2.7

Vlastimil Brom vlastimil.brom at gmail.com
Thu Jul 21 19:30:36 CEST 2011


2011/7/21 JB <jamie_brewster at hotmail.com>:
> I'm currently using python 2.7, with numpy and scipy already
> installed, but I can't seem to install Scikits.timeseries. I've
> downloaded the windows installer from sourceforge, but when I run it,
> it checks for a 2.6 installation, and obviously doesn't find the 2.7
> folder. Anyone know of a 2.7 installer?
>
> Thanks
> --
> http://mail.python.org/mailman/listinfo/python-list
>

Hi,
it appears, you can use the universal source installer:
scikits.timeseries-0.91.3.tar.gz
from
http://sourceforge.net/projects/pytseries/files/scikits.timeseries/0.91.3/

setuptools seems to be  required for installation of this package:
http://pypi.python.org/pypi/setuptools

After installing that, just unpack the archive
scikits.timeseries-0.91.3.tar.gz

and call the contained setup.py with your python 2.7 with the parameter: install

setup.py install
(assuming you are in the appropriate directory like:
C:\install\scikits.timeseries-0.91.3\
and python27 is associated as the default python interpreter;
otherwise the full paths should be specified.

I am not able to test the functionality on py27, but at least import,
help(...) and some basic stuff do work :-)

hth,
  vbr



More information about the Python-list mailing list