Tcl/tk version in Python installation

Baruch Lifshitz baruchli at gmail.com
Sun Dec 2 07:05:57 CET 2012


I need help of those who familiar with Python-Tcl/tk bundle.

I cannot start IDLE IDE for Python 3.2.3 or 3.3.0 installation. Command

python -m idlelib.idle
gives next output:

   C:\Python33>python -m idlelib.idle
   Traceback (most recent call last):
   File "C:\Python33\lib\runpy.py", line 160, in _run_module_as_main
    "__main__", fname, loader, pkg_name)
  File "C:\Python33\lib\runpy.py", line 73, in _run_code
    exec(code, run_globals)
  File "C:\Python33\lib\idlelib\idle.py", line 11, in <module>
    idlelib.PyShell.main()
  File "C:\Python33\lib\idlelib\PyShell.py", line 1421, in main
    root = Tk(className="Idle")
  File "C:\Python33\lib\tkinter\__init__.py", line 1756, in __init__
    self.tk = _tkinter.create(screenName, baseName, className, interactive, want
objects, useTk, sync, use)
_tkinter.TclError: Can't find a usable init.tcl in the following directories:
    {C:\Program Files\CSR\BlueSuite 2.4} C:/Python33/lib/tcl8.5 C:/lib/tcl8.5 C:
/lib/tcl8.5 C:/library C:/library C:/tcl8.5.11/library C:/tcl8.5.11/library
Actually init.tcl is located both in C:\Python33\tcl\tcl8.5 and C:\Python33\tcl\tix8.4.3 but something preventing tkinter from starting.

During previous attempts to start idlelib.idle module form command line I got message

 "Tcl": have 8.5.11, need exactly 8.4 
So this is a stage I can't pass. What in the system may force me to use Tcl 8.4 and prevent form using 8.5.11 installed with Python 3.3.0?

Thank you in advance.



More information about the Python-list mailing list