Unicode

Anatoli Hristov tolidtm at gmail.com
Mon Dec 17 23:31:42 CET 2012


> I doubted that 2.7 would make any difference.

Yeah this complicated my life even more, all my import functions was
gone - took me 2h to fix all :)
and it does not solved my issue:)
>
> 1. What does your "terminal' expect. (For all I know you're using
> TeraTermPro as a terminal, which doesn't support utf-8.)
> Have you looked at the terminal encoding to see what your copy of
> Terminal is expecting? On my Ubuntu Linux, I open the terminal with
> Ctrl-Alt-t, then in the menu bar, I select
> Terminal->SetCharacterEncoding->utf-8

I'm using putty for windows and I changed the putty to UTF-8 and this
is what solved the problem - ihuuuuuu :p
There is no logic, but it solved the issue !

> 2. What does your environment tell Linux to support? At a bash prompt, try
> echo $LANG (there are two other environment variables I've seen
> reference to, so this aspect is nuts)
> Mine says
> en_US.UTF-8

Mine too US.UTF-8, but the putty was in latin1

> 3. What does Python think it was told?
> import sys
> print sys.stdout.encoding
>
> Mine says
> UTF-8
Mine too :p

Thank you Dave you always come with a solution :)



More information about the Python-list mailing list