Fuzzy Logic Library for Python 3

Terry Reedy tjreedy at udel.edu
Thu Dec 20 01:21:46 CET 2012


On 12/19/2012 9:22 AM, Alexsandro Soares wrote:
> Hi all,
>
>     I'm trying to build an fuzzy expert system in Python 3 and I need a
> good recommendation for a library/package for this, but working in
> Python 3.2. Some options are pyfuzzy and pyfuzzylib,

Please tell the authors that you would like to use with Py3 but can't. 
One reason people have had for not upgrading is because there is 'no 
demand'. Of course, happy 2.x users are mostly happy to continue with 
2.x, whereas potential 3.x users usually silently move on.

 >  but I was not
> succeed to install these packages with Python 3.

I do not know about installation issues and how there are related to 
Py3. I would expect that most of the actual code should run with little 
or no change. The only change in arithmetic is int / int, and that can 
be given the Py3 meaning in 2.6/7 with a future import.

-- 
Terry Jan Reedy




More information about the Python-list mailing list