Virtualenv loses context

rhythmicdevil at gmail.com rhythmicdevil at gmail.com
Thu Dec 20 13:50:42 CET 2012


Brought my laptop out of hibernation to do some work this morning. I attempted to run one of my ETLs and got the following error. I made no changes since it was running yesterday.



[swright at localhost app]$ python etl_botnet_meta.py --mode dev -f
Traceback (most recent call last):
  File "etl_botnet_meta.py", line 9, in <module>
    from make_zip import EtlMakeZip
  File "/home/swright/workspace/botnet_etl/app/make_zip.py", line 1, in <module>
    import M2Crypto, os, time, datetime, json, hashlib, base64, zipfile
ImportError: No module named M2Crypto
[swright at localhost app]$ python -m site
sys.path = [
    '/home/swright/workspace/botnet_etl/app',
    '/usr/lib/python2.6/site-packages/pymongo-2.3-py2.6-linux-x86_64.egg',
    '/usr/lib/python2.6/site-packages/pip-1.2.1-py2.6.egg',
    '/usr/lib64/python26.zip',
    '/usr/lib64/python2.6',
    '/usr/lib64/python2.6/plat-linux2',
    '/usr/lib64/python2.6/lib-tk',
    '/usr/lib64/python2.6/lib-old',
    '/usr/lib64/python2.6/lib-dynload',
    '/usr/lib64/python2.6/site-packages',
    '/usr/lib64/python2.6/site-packages/gst-0.10',
    '/usr/lib64/python2.6/site-packages/gtk-2.0',
    '/usr/lib64/python2.6/site-packages/webkit-1.0',
    '/usr/lib/python2.6/site-packages',
    '/usr/lib/python2.6/site-packages/setuptools-0.6c11-py2.6.egg-info',
]
USER_BASE: '/home/swright/.local' (exists)
USER_SITE: '/home/swright/.local/lib/python2.6/site-packages' (doesn't exist)
ENABLE_USER_SITE: True
[swright at localhost app]$



More information about the Python-list mailing list