Disable use of pyc file with no matching py file

Roy Smith roy at panix.com
Wed Feb 1 05:14:24 CET 2012


In article <mailman.5264.1328054130.27778.python-list at python.org>,
 Terry Reedy <tjreedy at udel.edu> wrote:

> But I am sure that 95% of readers here will be using 3.x withing 10 
> years. The only question for them is "When?". This not-well-known new 
> feature is one straw that some will put on the 'sooner' side of the balance.

We would love to move to 3.x, for the better unicode support, if nothing 
else.  What's keeping us from doing so is the host of third-party 
modules and tools we depend on that don't yet support 3.x.  Off the top 
of my head (it's possible some of these already have support):

django (I understand it's been done, if not yet officially supported)
pymongo
mongoengine
tornado
pybeanstalk
dateutils
requests
lxml
blinker
gunicorn
I'm sure I've missed a few

It's getting to the point where any open-source python project needs to 
either jump on the 3.x bandwagon or get consigned to obscurity.  I'm 
guessing that's going to start happening in a big way in 2012.



More information about the Python-list mailing list