select module missing/corrupt

Emile van Sebille emile at fenx.com
Sat Jul 7 16:45:15 CEST 2012


On 7/7/2012 5:03 AM John Pote said...
> We are using a virtual web server running some version of Unix. It has
> Python versions 2.4,2.6 and 3.1 pre-installed.
>
> (BTW the intention is to use Python for a CGI script.)
>
> When my script imports subprocess I get the traceback
> File "/usr/lib/python2.6/subprocess.py", line 427, in <module>
> import select
> ImportError: No module named select
>
> On searching the Python installation I found what I presume is the
> select module library file
>
> /usr/lib/python2.6/lib-dynload/select_failed.so
>
> whereas in the 2.4 installation the file is
> /usr/lib/python2.4/lib-dynload/select.so
> and subprocess imports OK.
>
> Anyone know why the version 2.6 select .so file should be renamed
> select_failed.so and so not able to be imported?


When python builds, modules that don't build cleanly get renamed 
[module]_failed.  See 
http://mail.python.org/pipermail/python-dev/2002-March/020568.html for 
more info.

Emile



>
> Of interest the 3.1 installation also has the select module file
> re-named select_failed.so.
>
> Any help appreciated,
>
> Regards,
> John Pote
>
>
> --- Posted via news://freenews.netfront.net/ - Complaints to
> news at netfront.net ---





More information about the Python-list mailing list