from future import pass_function
ethan at stoneleaf.us
Fri Jul 27 00:35:51 CEST 2012
John Ladasky wrote:
> I had very similar thoughts about eight months ago, and posted them here:
> I'm no computer science guru, but the idea that pass should be a function rather than a statement continues to appeal to me. As you can see, I actually wrote just such a function so that I could use it as an argument in my code.
I would have called `no_op` or `nop` -- `pass` does just what it says:
it passes and does zero work. Your _pass does do work, just useless
work. Sometimes that's necessary, but I wouldn't call it `_pass`.
More information about the Python-list