What's the best way to write this regular expression?

Chris Angelico rosuav at gmail.com
Thu Mar 8 06:03:34 CET 2012


On Thu, Mar 8, 2012 at 7:39 AM, John Salerno <johnjsal at gmail.com> wrote:
> it only
> seemed to support Python 2.7. I'm using 3.2. Is 2.7 just the minimum
> version it requires? It didn't say something like "2.7+", so I wasn't
> sure, and I don't want to start installing a bunch of stuff that will
> clog up my directories and not even work.

Just to clarify: Python 2 and Python 3 are quite different. If
something requires Python 2.7, you cannot assume that it will work
with Python 3.2; anything that supports both branches will usually
list the minimum version of each (eg "2.7 or 3.3").

ChrisA



More information about the Python-list mailing list