why did GMPY change the names of its functions?

Mensanator mensanator at aol.com
Mon Mar 26 06:59:56 CEST 2012


OK, GMPY is now called GMPY2. No big deal, I can import as GMPY.

But why were scan0 and scan1 changed to bit_scan0 and bit_scan1?

What's the justification for that? I use those functions extensively
in my library of Collatz utilities  and I had to re-edit them for no
obvious reason.



More information about the Python-list mailing list