Will MySQL ever be supported for Python 3.x?

Irmen de Jong irmen.NOSPAM at xs4all.nl
Fri Mar 30 23:55:59 CEST 2012


On 30-3-2012 23:46, John Nagle wrote:
> On 3/30/2012 2:32 PM, Irmen de Jong wrote:
>> Try Oursql instead  http://packages.python.org/oursql/
>> "oursql is a new set of MySQL bindings for python 2.4+, including python 3.x"
> 
>    Not even close to being compatible with existing code.   Every SQL
> statement has to be rewritten, with the parameters expressed
> differently.  It's a good approach, but very incompatible.

You didn't state that it had to be compatible with existing code.
Also, since you asked about Python 3.x, surely there are other incompatibilities you
need to take care of in the existing code? (unless it's Python 3.x clean already...)

Irmen



More information about the Python-list mailing list