There must be a better way
Jussi Piitulainen
jpiitula at ling.helsinki.fi
Sun Apr 21 09:39:07 EDT 2013
Colin J. Williams writes:
...
> It is not usual to have a name with preceding and following
> udserscores,imn user code.
>
> Presumably, there is a rationale for the change from csv.reader.next
> to csv.reader.__next__.
...
I think the user code is supposed to be next(csv.reader). For example,
current documentation contains the following.
# csvreader.__next__()
# Return the next row of the reader’s iterable object as a list,
# parsed according to the current dialect. Usually you should call
# this as next(reader).
More information about the Python-list
mailing list