Python 3.3.2 Shell Message

stanward at gmail.com stanward at gmail.com
Sun Dec 29 20:38:26 CET 2013


Hi Ned,

I am running into the same problem described by Bart.  I am teaching my kids to program using the Python For Kids book on a Mac OSX 10.8.5.


I have installed "Mac OS X 64-bit/32-bit Installer (3.3.3) for Mac OS X 10.6 and later" (file: python-3.3.3-macosx10.6.dmg) and installed the "ActiveTcl 8.6.1 for Mac OS X (10.5+, x86_64/x86)" (file: ActiveTcl8.6.1.1.297588-macosx10.5-i386-x86_64-threaded), but IDLE keeps showing the message "WARNING: The version of Tcl/Tk (8.5.9) in use may be unstable. Visit http://www.python.org/download/mac/tcltk/ for current information."

Per your instructions in the thread http://code.activestate.com/lists/python-dev/117314/ I have inspected the IDLE process using Activity Monitor and the Tcl/Tk processes being used are:
/System/Library/Frameworks/Tcl.framework/Versions/8.5/Tcl
/System/Library/Frameworks/Tk.framework/Versions/8.5/Tk

Is there a PATH setting or something I can use to force the use of the ActiveTcl Tcl/Tk located in:
/Library/Frameworks/Tcl.framework/Versions/8.5/Tcl and
/Library/Frameworks/Tk.framework/Versions/8.5/Tk

I have tried a bunch of different things all to no avail, so I am now reaching for help.  I have UNIX experience and a CS degree, although very rusty, so have at with any technical instructions.  Thank you very much!!!



More information about the Python-list mailing list