A newbie question

Colin J. Williams cjw at ncf.ca
Tue Feb 12 17:03:04 CET 2013


On 12/02/2013 10:06 AM, Alberto Salvati wrote:
> Hi, All.
> I'm a (old....) delphi developer.
> I want to learn Python.
> I've python 2.7 and django.
> For learning purpose I want to use firebird.
> But, package (egg) to use firebird needs easy_install for setup.
> When i run:
>
> python ez_setup.py install
>
> python says me error:
>
> Downloading http://pypi.python.org/packages/2.7/s/setuptools/setuptools-0.6c11-p
> y2.7.egg
> Searching for install
> Reading http://pypi.python.org/simple/install/
> Couldn't find index page for 'install' (maybe misspelled?)
> Scanning index of all packages (this may take a while)
> Reading http://pypi.python.org/simple/
> No local packages or download links found for install
> Best match: None
> Traceback (most recent call last):
>    File "ez_setup.py", line 278, in <module>
>      main(sys.argv[1:])
>    File "ez_setup.py", line 213, in main
>      return main(list(argv)+[egg])   # we're done here
>    File "C:\Python27\Scripts\setuptools-0.6c11-py2.7.egg\setuptools\command\easy_
> install.py", line 1712, in main
>    File "C:\Python27\Scripts\setuptools-0.6c11-py2.7.egg\setuptools\command\easy_
> install.py", line 1700, in with_ei_usage
>    File "C:\Python27\Scripts\setuptools-0.6c11-py2.7.egg\setuptools\command\easy_
> install.py", line 1716, in <lambda>
>    File "C:\Python27\lib\distutils\core.py", line 152, in setup
>      dist.run_commands()
>    File "C:\Python27\lib\distutils\dist.py", line 953, in run_commands
>      self.run_command(cmd)
>    File "C:\Python27\lib\distutils\dist.py", line 972, in run_command
>      cmd_obj.run()
>    File "C:\Python27\Scripts\setuptools-0.6c11-py2.7.egg\setuptools\command\easy_
> install.py", line 211, in run
>    File "C:\Python27\Scripts\setuptools-0.6c11-py2.7.egg\setuptools\command\easy_
> install.py", line 434, in easy_install
>    File "C:\Python27\Scripts\setuptools-0.6c11-py2.7.egg\setuptools\package_index
> .py", line 475, in fetch_distribution
> AttributeError: 'NoneType' object has no attribute 'clone'
>
>
> In download site I get info about installer works only on win32, but I'm uisng 64 bit version, so I need to do setup manually.
>
> Searching error, I see a lot of message baout errors AFTER easy_install was done.
> Also, I see that some link used in python file does'nt exist or is broken.
>
> TIA for any suggestion.
>
> A.
>
Try Easy_install, but first, make sure that C:\Python27\Scripts is in 
your path.

Colin W.

PS Assuming you are using Windows, you might wish to try PyScripter.  I 
was developed using Delphi.




More information about the Python-list mailing list